Search This Blog

Tuesday, May 8, 2018

FP9 failed to install because certificate expired since Fri Apr 20

Hi

Today I wasted some time on issue with installation of FP9.

I reinstalled Windows on my laptop, installed IBM Notes client 9.0.1 and then tried to install FP9 using setup file I used many times before. However this time installation failed. At first I thought it was caused by my Windows because I like to disable in Windows everything I can. However when I tried to install FP9 on another VM I had got the same issue:



I read logs provided by FP9 installation but didn't find anything helpful there, just

CustomAction PreRunProvisioning.5F3129E8_3AD4_4346_AEE6_A314E2DE64D9 returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 18:51:01: InstallFinalize. Return value 3.

Then I checked logs in IBM\Notes\Data\workspace\logs and found there a following line:

CWPST1015W: Plugin com.ibm.rcp.provisioning.feature_9.0.1.20170629-1747 failed to install.   
The reason provided is CWPST1002W: Signature has expired


Then I googled this post and used workaround by adding setting com.ibm.rcp.security.update/EXPIRED_SIGNATURE_POLICY=ALLOW to plugin_customization.ini - worked OK for me.

2 comments:

  1. Hi, have you tried the FP9 IF3 http://www-01.ibm.com/support/docview.wss?uid=swg21657963

    ReplyDelete